summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon Josefsson <simon@josefsson.org>2004-08-10 12:07:48 +0000
committerSimon Josefsson <simon@josefsson.org>2004-08-10 12:07:48 +0000
commitda9cb81ebf3d09a231f62dd4d80c3e785bc95df9 (patch)
tree2bc131033166e3096626005a203fcabd49cf5fb5 /configure.in
parent3d345eb461ccc697e713b310eb9e67e10400a59e (diff)
downloadgnutls-da9cb81ebf3d09a231f62dd4d80c3e785bc95df9.tar.gz
If socklen_t doesn't exist, use size_t (needed for Darwin).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4b5384eb46..7eb9f20c84 100644
--- a/configure.in
+++ b/configure.in
@@ -272,6 +272,18 @@ AC_CHECK_TYPE(time_t,
AC_C_BIGENDIAN
+AC_CHECK_TYPE([socklen_t],, [AC_DEFINE([socklen_t], [size_t],
+ [Define to `size_t' if `socklen_t' is missing.])], [
+#ifdef HAVE_SYS_TYPES_H
+#include <sys/types.h>
+#endif
+#ifdef HAVE_SYS_SOCKET_H
+#include <sys/socket.h>
+#endif
+#ifdef HAVE_NETDB_H
+#include <netdb.h>
+#endif
+])
AC_MSG_RESULT([***
*** Checking for external libraries...