summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2004-05-16 15:15:23 +0000
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2004-05-16 15:15:23 +0000
commit07b80e83a85d856a35052798763c437139a2ff52 (patch)
treeb1d1fba7038b90cb6a6ec661f0cc68bf51d223c3 /configure.in
parent7c28c9da061436051bee7250e344e62710994efd (diff)
downloadgnutls-07b80e83a85d856a35052798763c437139a2ff52.tar.gz
added proper libtasn1 version detection.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 6 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 2e72595441..76ad291949 100644
--- a/configure.in
+++ b/configure.in
@@ -18,7 +18,7 @@ GNUTLS_VERSION=$GNUTLS_MAJOR_VERSION.$GNUTLS_MINOR_VERSION.$GNUTLS_MICRO_VERSION
AC_DEFINE_UNQUOTED(GNUTLS_VERSION, "$GNUTLS_VERSION", [version of gnutls])
GNUTLS_GCRYPT_VERSION=1:1.1.94
-GNUTLS_LIBTASN1_VERSION=0.2.5
+GNUTLS_LIBTASN1_VERSION=0.2.10
AC_DEFINE_UNQUOTED(GNUTLS_GCRYPT_VERSION, "$GNUTLS_GCRYPT_VERSION", [version of gcrypt])
AC_DEFINE_UNQUOTED(GNUTLS_LIBTASN1_VERSION, "$GNUTLS_LIBTASN1_VERSION", [version of libtasn1])
@@ -368,20 +368,16 @@ AM_CONDITIONAL(ENABLE_OPENSSL, test "$ac_enable_openssl" = "yes")
AC_ARG_WITH(included-libtasn1,
[ --with-included-libtasn1 Use the included libtasn1],
minitasn1_enabled=$withval,
-minitasn1_enabled=no
+minitasn1_enabled=no)
dnl We now need libtasn1 0.2.x
dnl
-AC_CHECK_LIB( tasn1, asn1_read_tag,:,
+AM_PATH_LIBTASN1($GNUTLS_LIBTASN1_VERSION,,
minitasn1_enabled=yes
-AC_MSG_WARN([[
+ AC_MSG_WARN([[
***
-*** LibtASN1 0.2.x was not found. Will use the included one.]])))
-
-
-if test x$opt_developer_mode = xyes; then
- minitasn1_enabled=yes
-fi
+*** LibtASN1 0.2.x was not found. Will use the included one.
+]]))
SAVED_LIBS=$LIBS
@@ -455,10 +451,6 @@ if test x$use_lzo = xyes; then
AC_DEFINE(USE_LZO, 1, [whether to use the lzo compression])
-if test x$opt_developer_mode = xyes; then
- minilzo_enabled=yes
-fi
-
AC_ARG_WITH(included-lzo,
[ --with-included-lzo include minilzo in libgnutls-extra],
minilzo_enabled=$withval,