summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2018-11-09 07:44:02 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2018-11-10 07:20:16 +0100
commit5c7db52d2471d13d6c8e6c2e763d3ba2560d6cad (patch)
tree1ee88469b6907aa15b275a77d5ed306629f0298a /configure.ac
parentf3da49beff97b399325f4616b6096d7bbdec268d (diff)
downloadgnutls-5c7db52d2471d13d6c8e6c2e763d3ba2560d6cad.tar.gz
tls13: use system's openssl for interop testing
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f87907516..31a5da83ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,6 +187,12 @@ esac
fi
+AC_ARG_ENABLE(tls13-interop,
+ AS_HELP_STRING([--disable-tls13-interop], [disable TLS1.3 interoperability testing with openssl]),
+ enable_tls13_interop=$enableval, enable_tls13_interop=yes)
+
+AM_CONDITIONAL(ENABLE_TLS13_INTEROP, test "$enable_tls13_interop" != "no")
+
dnl Check for iovec type
AC_CHECK_MEMBERS([struct iovec.iov_base],
[