summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-11-12 15:48:14 +0100
committerDaiki Ueno <dueno@redhat.com>2018-11-13 10:07:59 +0100
commit11c5a3ba0cdf4fcf10094d7dc1f1a8a5a622b8b0 (patch)
treeaabe4807f4dcb5a394642f7d7ef69172f496e0d2 /configure.ac
parent7e73fb75989719299a7fdc67488457dd175f2012 (diff)
downloadgnutls-11c5a3ba0cdf4fcf10094d7dc1f1a8a5a622b8b0.tar.gz
build: use AM_MISSING_PROG for autogen
That makes error message more friendly when autogen is not installed on developing environment. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index dc38c538e5..5e915eac53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,12 +711,14 @@ fi
AC_DEFINE_UNQUOTED([TROUSERS_LIB], ["$ac_trousers_lib"], [the location of the trousers library])
AC_SUBST(TROUSERS_LIB)
+AM_MISSING_PROG([AUTOGEN], [autogen])
+
included_libopts=no
create_libopts_links=no
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
- AC_CHECK_PROG([AUTOGEN], [autogen], [autogen], [:])
+ AC_CHECK_PROGS([autogen], [autogen])
- if test x"$AUTOGEN" = "x:"; then
+ if test -z "$autogen"; then
AC_MSG_WARN([[
***
*** autogen not found. Will not link against system libopts.
@@ -728,13 +730,11 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
if test "$NEED_LIBOPTS_DIR" = "true";then
dnl replace libopts-generated files with distributed backups, if present
create_libopts_links=yes
- AC_SUBST([AUTOGEN], [/bin/true])
included_libopts=yes
fi
else
# Need to ensure the relevant conditionals get set
gl_STDNORETURN_H
- AC_SUBST([AUTOGEN], [/bin/true])
AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
fi