summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2017-03-12 14:48:19 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-03-13 08:29:54 +0100
commit1f246c381e8a7449d84b143ffe50a0818622d2a3 (patch)
tree9f753dd6e32a678aef01247fbc3168930542b966 /configure.ac
parent96476f5da225b46d3ab17eb3494ae4a24cca9525 (diff)
downloadgnutls-1f246c381e8a7449d84b143ffe50a0818622d2a3.tar.gz
lib: unconditionally enable the self-check functionstmp-pkcs11-avoid-locks
These functions were previously made available only in FIPS140-2 mode. Enabling them unconditionally allows applications to directly utilize that functionality for testing the gnutls library. Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index e7e0a1492b..71f53a083a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -431,20 +431,14 @@ LT_INIT([disable-static,win32-dll,shared])
-AC_ARG_ENABLE(self-checks,
- AS_HELP_STRING([--enable-self-checks], [enable self checking functionality]),
- enable_self_checks=$enableval, enable_self_checks=no)
-
AC_LIB_HAVE_LINKFLAGS(dl,, [#include <dlfcn.h>], [dladdr (0, 0);])
AC_ARG_ENABLE(fips140-mode,
- AS_HELP_STRING([--enable-fips140-mode], [enable FIPS140-2 mode (implies self checks)]),
+ AS_HELP_STRING([--enable-fips140-mode], [enable FIPS140-2 mode]),
enable_fips=$enableval, enable_fips=no)
AM_CONDITIONAL(ENABLE_FIPS140, test "$enable_fips" = "yes")
if [ test "$enable_fips" = "yes" ];then
if test "x$HAVE_LIBDL" = "xyes";then
- enable_self_checks=yes
-
AC_DEFINE([ENABLE_FIPS140], 1, [Enable FIPS140-2 mode])
AC_SUBST([FIPS140_LIBS], $LIBDL)
AC_ARG_WITH(fips140-key, AS_HELP_STRING([--with-fips140-key],
@@ -550,11 +544,6 @@ if test "$enable_non_suiteb" = "yes";then
fi
AM_CONDITIONAL(ENABLE_NON_SUITEB_CURVES, test "$enable_non_suiteb" = "yes")
-AM_CONDITIONAL(ENABLE_SELF_CHECKS, test "$enable_self_checks" = "yes")
-if [ test "$enable_self_checks" = "yes" ];then
- AC_DEFINE([ENABLE_SELF_CHECKS], 1, [Self checks are included in the library])
-fi
-
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],
@@ -1066,7 +1055,6 @@ if features are disabled)
Anon auth support: $ac_enable_anon
Heartbeat support: $ac_enable_heartbeat
IDNA support: $idna_support
- Self checks: $enable_self_checks
Non-SuiteB curves: $enable_non_suiteb
FIPS140 mode: $enable_fips
])