summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-07-01 14:29:40 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2016-07-05 14:50:47 +0200
commitc80220e0556e9b21299a5281f9e3ec1fb1a78676 (patch)
tree8541509f887d4aec6148a0971b5709c1a52e4218 /configure.ac
parent24a7ccb0f0adb935053aa6c5e326150812e94cc5 (diff)
downloadgnutls-c80220e0556e9b21299a5281f9e3ec1fb1a78676.tar.gz
tests: added openssl compatibility tests for AES-GCM cipher
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b6653d1c37..226fd7432f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,6 +255,12 @@ AM_CONDITIONAL(HAVE_SECCOMP_TESTS, test "$seccomp_tests" = "yes")
AC_LIB_HAVE_LINKFLAGS(seccomp,, [#include <seccomp.h>
], [seccomp_init(0);])
+# check for libcrypto - used in test programs
+AC_LIB_HAVE_LINKFLAGS(crypto,, [#include <openssl/evp.h>
+], [EVP_CIPHER_CTX_init(NULL);])
+
+AM_CONDITIONAL(HAVE_LIBCRYPTO, test "$HAVE_LIBCRYPTO" = "yes")
+
AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>
#include <signal.h>
], [timer_create (0,0,0);])