summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rühsen <tim.ruehsen@gmx.de>2016-07-28 09:55:27 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-07-28 14:33:24 +0200
commitb45f02bf65a3842f380f1041d31f1a659cf40fdb (patch)
tree8bb21fbd36a1b0f423b9acfef95bd21c6c83ddd0 /configure.ac
parentb70034afa4c6038e5d5e3bf3085cfc9cf1f25d50 (diff)
downloadgnutls-b45f02bf65a3842f380f1041d31f1a659cf40fdb.tar.gz
Require compiler to support C99
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8175759d6d..492871c1f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,14 @@ AC_PROG_SED
AC_USE_SYSTEM_EXTENSIONS
+#
+# Require C99 support
+#
+AC_PROG_CC_C99
+if test "$ac_cv_prog_cc_c99" = "no"; then
+ AC_MSG_WARN([[Compiler does not support C99. It may not be able to compile the project.]])
+fi
+
AX_CODE_COVERAGE
AC_ARG_ENABLE(doc,