summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-05-31 10:00:18 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-05-31 13:55:57 +0200
commit6ffab60f62c8022d925961bb8e19de3d76011708 (patch)
tree449d031c1758769e02a756c5c8dde3726ff826b5 /configure.ac
parentdac31a3aa2fa15d712283628085ee78a7c8548c9 (diff)
downloadgnutls-6ffab60f62c8022d925961bb8e19de3d76011708.tar.gz
configure: enable the type-limits gcc warnings
In addition remove the unsafe-loop-optimizations warning as they were not helpful.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index beef3ca719..f108571d81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -333,6 +333,7 @@ AC_ARG_ENABLE([gcc-warnings],
if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wframe-larger-than=4096], [WSTACK_CFLAGS])
+ gl_WARN_ADD([-Wtype-limits], [WSTACK_CFLAGS])
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wc++-compat" # We don't care about C++ compilers
@@ -353,6 +354,7 @@ if test "$gl_gcc_warnings" = yes; then
nw="$nw -Wsuggest-attribute=const" # Is it worth using attributes?
nw="$nw -Wsuggest-attribute=noreturn" # Is it worth using attributes?
nw="$nw -Wstack-protector" # Some functions cannot be protected
+ nw="$nw -Wunsafe-loop-optimizations" # Warnings with no point
nw="$nw -Wredundant-decls" # Some files cannot be compiled with that (gl_fd_to_handle)
gl_MANYWARN_ALL_GCC([ws])