summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2016-08-07 12:56:21 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-08-08 08:51:19 +0200
commita30a5359f9dd55e31d97925dfcf45f12ecaae37c (patch)
tree0c8b1cce4d3ee2a640f6d95470ce597746673a94 /configure.ac
parent0470bf60104410e183e90bb1d21ccc151a545c44 (diff)
downloadgnutls-a30a5359f9dd55e31d97925dfcf45f12ecaae37c.tar.gz
tests: added check for errors when importing illegal RSA keys
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d933ff5de4..0ba22300e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,6 +456,12 @@ AC_ARG_WITH(idn, AS_HELP_STRING([--without-idn],
try_libidn="$withval",
try_libidn=yes)
+with_old_nettle=no
+if ! $PKG_CONFIG --atleast-version=3.3 nettle; then
+ with_old_nettle=yes
+fi
+AM_CONDITIONAL(WITH_OLD_NETTLE, test "$with_old_nettle" != "no")
+
if test "$try_libidn" = yes;then
PKG_CHECK_MODULES(LIBIDN, libidn >= 0.5.6, [with_libidn=yes], [with_libidn=no])
if test "$with_libidn" != "no";then