summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-09-23 14:55:37 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-10-03 13:53:05 +0200
commit0be469e510d9acb18a5a66733d258eb1e72435d3 (patch)
treede4b5c0fa5ef4a5480b48c4f30a5db6be697ebfb /configure.ac
parent77b5cb53902087769cbfd801d46083525451b840 (diff)
downloadgnutls-0be469e510d9acb18a5a66733d258eb1e72435d3.tar.gz
Imported Andy Polyakov's implementations for SHA* in aarch64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06640631cf..dccd6d8d2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,6 +153,9 @@ hw_accel=none
use_padlock=no
if test "$use_accel" != "no"; then
case $host_cpu in
+ armv8 | aarch64)
+ hw_accel="aarch64"
+ ;;
i?86 | x86_64 | amd64)
AC_CHECK_HEADERS(cpuid.h)
if test "$host_cpu" = "x86_64" || test "$host_cpu" = "amd64"; then
@@ -196,6 +199,7 @@ if test "$use_padlock" != "no"; then
AC_SUBST([ENABLE_PADLOCK])
fi
AM_CONDITIONAL(ENABLE_PADLOCK, test "$use_padlock" = "yes")
+AM_CONDITIONAL(ASM_AARCH64, test x"$hw_accel" = x"aarch64")
AM_CONDITIONAL(ASM_X86_64, test x"$hw_accel" = x"x86-64")
AM_CONDITIONAL(ASM_X86_32, test x"$hw_accel" = x"x86")
AM_CONDITIONAL(ASM_X86, test x"$hw_accel" = x"x86" || test x"$hw_accel" = x"x86-64")
@@ -920,6 +924,7 @@ AC_CONFIG_FILES([
lib/Makefile
lib/accelerated/Makefile
lib/accelerated/x86/Makefile
+ lib/accelerated/aarch64/Makefile
lib/algorithms/Makefile
lib/auth/Makefile
lib/ext/Makefile