summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-20 12:04:09 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-04-20 13:45:35 +0200
commit7cf782bf02d2749490f98355f53bf82762f90798 (patch)
tree759892ff8e2fd28ee844329c739c28e4b405f082 /configure.ac
parent4cba60e475929234ec42803dea6c979978f2b324 (diff)
downloadgnutls-7cf782bf02d2749490f98355f53bf82762f90798.tar.gz
tests: use mmap() for large memory allocations in systems that support it
That allows the hash-large test to run on systems which its calloc() is attempting to allocate an impossible amount of memory.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c04b39da34..ec08be8eb4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,7 +215,7 @@ AC_C_BIGENDIAN
dnl No fork on MinGW, disable some self-tests until we fix them.
dnl Check clock_gettime and pthread_mutex_lock in libc (avoid linking to other libs)
-AC_CHECK_FUNCS([fork inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid clock_gettime iconv localtime fmemopen vasprintf],,)
+AC_CHECK_FUNCS([fork inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid clock_gettime iconv localtime fmemopen vasprintf mmap],,)
if test "$ac_cv_func_vasprintf" != "yes";then
AC_MSG_CHECKING([for va_copy])
AC_LINK_IFELSE([AC_LANG_PROGRAM([