summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-12-06 10:48:52 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-12-06 10:48:52 +0100
commitb93f27dc3df7af0684c00582ddb34029774fdfe1 (patch)
treeaa5e3597fac82ba2c144eceb1498aa45da0b606a /configure.ac
parent5395d76803a424bfbb2caf775629d125cd38a038 (diff)
downloadgnutls-b93f27dc3df7af0684c00582ddb34029774fdfe1.tar.gz
configure: added option --without-idn
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 866b2b6b09..a08d6f3102 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,6 +356,12 @@ if [ test "$enable_fips" = "yes" ];then
fi
fi
+AC_ARG_WITH(idn, AS_HELP_STRING([--without-idn],
+ [disable support for libidn]),
+ try_libidn="$withval",
+ try_libidn=yes)
+
+if test "$try_libidn" = yes;then
PKG_CHECK_MODULES(LIBIDN, libidn >= 0.5.6, [with_libidn=yes], [with_libidn=no])
if test "$with_libidn" != "no";then
AC_DEFINE([HAVE_LIBIDN], 1, [Build IDNA support])
@@ -371,6 +377,9 @@ else
*** libidn was not found. IDNA support will be disabled.
*** ]])
fi
+else
+ with_libidn=no
+fi
AM_CONDITIONAL(HAVE_LIBIDN, test "$with_libidn" != "no")
@@ -896,7 +905,7 @@ if features are disabled)
ECDHE support: $ac_enable_ecdhe
Anon auth support: $ac_enable_anon
Heartbeat support: $ac_enable_heartbeat
- IDNA support: $libidn
+ IDNA support: $with_libidn
Unicode support: $ac_have_unicode
Self checks: $enable_self_checks
Non-SuiteB curves: $enable_non_suiteb