summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlon Bar-Lev <alon.barlev@gmail.com>2015-12-18 12:14:08 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-12-18 16:10:35 +0100
commitaf385d1552c0d5854db6db03c82e1e9b89e80b94 (patch)
treea75d4838f9df6fccb1f4223cd36a2c67d5c9cb0d /configure.ac
parent15127ff7aa674b25827c4017a4584261613d4cc9 (diff)
downloadgnutls-af385d1552c0d5854db6db03c82e1e9b89e80b94.tar.gz
build: allow installing man(1) even with --disable-doc
Currently these man pages are installed only if --enable-doc is provided, while these are not actually docs, do not require any special dependency, nor consume large space. This adds --enable-manpages to enable/disable manpages installation, and install the man(1) regardless of --disable-doc. Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com> Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index efacc30092..23d7cd5ad2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,19 @@ AC_ARG_ENABLE(doc,
enable_doc=$enableval, enable_doc=yes)
AM_CONDITIONAL(ENABLE_DOC, test "$enable_doc" != "no")
+AC_ARG_ENABLE(manpages,
+ AS_HELP_STRING([--enable-manpages], [install manpages even if disable-doc is given]),
+ enable_manpages=$enableval,enable_manpages=auto)
+AM_CONDITIONAL(ENABLE_MANPAGES, test "$enable_manpages" != "no")
+
+if test "${enable_manpages}" = "auto";then
+ if test "$enable_doc" != "no";then
+ enable_manpages=yes
+ else
+ enable_manpages=no
+ fi
+fi
+
AC_ARG_ENABLE(tools,
AS_HELP_STRING([--disable-tools], [don't compile any tools]),
enable_tools=$enableval, enable_tools=yes)
@@ -935,6 +948,7 @@ AC_MSG_NOTICE([summary of build options:
Local libopts: ${included_libopts}
Local libtasn1: ${included_libtasn1}
Use nettle-mini: ${mini_nettle}
+ Documentation: ${enable_doc} (manpages: ${enable_manpages})
])
AC_MSG_NOTICE([External hardware support: