summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-07-21 16:33:34 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-07-21 16:57:39 +0200
commit9efd9d49e10ca77eb947cb3e1dfc23f6cf72fa38 (patch)
tree1559028ae9dc66e9434f19191aa94e711b94cda5 /configure.ac
parent41e5a4faca452280fdb35d6c487a3c3dd3ea01fd (diff)
downloadgnutls-9efd9d49e10ca77eb947cb3e1dfc23f6cf72fa38.tar.gz
Allow specifying a directory as trust store
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7e8aaf250..e3882af28e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -492,11 +492,20 @@ if test "x$with_default_trust_store_pkcs11" != x; then
["$with_default_trust_store_pkcs11"], [use the given pkcs11 uri as default trust store])
fi
+AC_ARG_WITH([default-trust-store-dir],
+ [AS_HELP_STRING([--with-default-trust-store-dir=DIR],
+ [use the given directory as default trust store])])
+
+if test "x$with_default_trust_store_dir" != x; then
+ AC_DEFINE_UNQUOTED([DEFAULT_TRUST_STORE_DIR],
+ ["$with_default_trust_store_dir"], [use the given directory as default trust store])
+fi
+
dnl auto detect http://lists.gnu.org/archive/html/help-gnutls/2012-05/msg00004.html
AC_ARG_WITH([default-trust-store-file],
[AS_HELP_STRING([--with-default-trust-store-file=FILE],
[use the given file default trust store])], with_default_trust_store_file="$withval",
- [if test "$build" = "$host" && test x$with_default_trust_store_pkcs11 = x;then
+ [if test "$build" = "$host" && test x$with_default_trust_store_pkcs11 = x && test x$with_default_trust_store_dir = x;then
for i in \
/etc/ssl/ca-bundle.pem \
/etc/ssl/certs/ca-certificates.crt \
@@ -823,6 +832,7 @@ AC_MSG_NOTICE([Optional libraries:
AC_MSG_NOTICE([System files:
Trust store pkcs11: $with_default_trust_store_pkcs11
+ Trust store dir: $with_default_trust_store_dir
Trust store file: $with_default_trust_store_file
Blacklist file: $with_default_blacklist_file
CRL file: $with_default_crl_file