summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2011-09-16 22:46:13 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2011-09-16 22:46:13 +0200
commitc8c99c59b4a09f8ade727bfb3276807d72961108 (patch)
treeed58271e0e8f29175d90f9ac5f99cf843d1fadec /configure.ac
parent10779454f169ab4616bb247cc6d141d56c16979c (diff)
downloadgnutls-c8c99c59b4a09f8ade727bfb3276807d72961108.tar.gz
Added better detection of capabilities in 386. If cpuid doesn't exist don't try to execute it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 85916ef627..a3ccb2cc91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -94,8 +94,8 @@ esac
fi
-AM_CONDITIONAL(TRY_X86_OPTIMIZATIONS, test x"$hw_accel" = x"x86" || test x"$hw_accel" = x"x86-64")
AM_CONDITIONAL(ASM_X86_64, test x"$hw_accel" = x"x86-64")
+AM_CONDITIONAL(ASM_X86_32, test x"$hw_accel" = x"x86")
AM_CONDITIONAL(HAVE_GCC_GNU89_INLINE_OPTION, test "$gnu89_inline" = "yes"])
AM_CONDITIONAL(HAVE_GCC, test "$GCC" = "yes")