summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-05-19 12:08:13 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-05-20 13:12:24 +0200
commitbfed722c69974526b0a3c28ee5d9d1c584cfa510 (patch)
treeed1cb92f2d93dcd51522d92fe892941f64b526ad /configure.ac
parentc9208c76a73a0bd7fae5a31427dad82d3dbd8c3d (diff)
downloadgnutls-bfed722c69974526b0a3c28ee5d9d1c584cfa510.tar.gz
configure.ac: increased stack size usage to reduce warnings
Also remove gcc flags from the banned list that no longer pose and issue.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 67ff1e2d87..6ab9cdcbf7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -330,7 +330,7 @@ AC_ARG_ENABLE([gcc-warnings],
)
if test "$gl_gcc_warnings" = yes; then
- gl_WARN_ADD([-Wframe-larger-than=2048], [WSTACK_CFLAGS])
+ gl_WARN_ADD([-Wframe-larger-than=4096], [WSTACK_CFLAGS])
nw="$nw -Wsystem-headers" # Don't let system headers trigger warnings
nw="$nw -Wc++-compat" # We don't care about C++ compilers
@@ -358,15 +358,8 @@ if test "$gl_gcc_warnings" = yes; then
for w in $ws; do
gl_WARN_ADD([$w])
done
- gl_WARN_ADD([-Wno-parentheses-equality]) # We need this one for clang warnings
- gl_WARN_ADD([-Wno-tautological-compare]) # We need this one for clang warnings
gl_WARN_ADD([-Wno-missing-field-initializers]) # We need this one
- gl_WARN_ADD([-Wno-format-y2k]) # Too many warnings for now
- gl_WARN_ADD([-Wno-unused-value]) # warnings for things we don't want to get
- gl_WARN_ADD([-Wno-unused-result]) # warnings for things we don't want to get
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
- gl_WARN_ADD([-Wno-stack-protector]) # Some functions cannot be protected
- gl_WARN_ADD([-Wno-int-to-pointer-cast]) # Some files cannot be compiled with that (gl_fd_to_handle)
gl_WARN_ADD([-fdiagnostics-show-option])
fi