summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-07-13 16:25:16 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-07-13 16:42:53 +0200
commit902de48cb362ed428fd8213a92522faa6070f00c (patch)
tree1972b03601a4062c3cff79809c45b10b99ba6b6d /configure.ac
parent222e6b61fd6010a6ce08bcb65a37f27f257c3ae8 (diff)
downloadgnutls-902de48cb362ed428fd8213a92522faa6070f00c.tar.gz
TPM: don't link to trousers, use dlopen()
That introduces --with-trousers-lib which can be used to specify the library to dlopen(). Resolves #18
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8f117e9468..f90b491117 100644
--- a/configure.ac
+++ b/configure.ac
@@ -529,6 +529,19 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
+if test -f "/usr/lib64/libtspi.so.1";then
+default_trousers_lib="/usr/lib64/libtspi.so.1"
+else
+default_trousers_lib="/usr/lib/libtspi.so.1"
+fi
+
+AC_ARG_WITH(trousers-lib, AS_HELP_STRING([--with-trousers-lib=LIB],
+ [set the location of the trousers library]),
+ ac_trousers_lib=$withval, ac_trousers_lib=$default_trousers_lib)
+
+AC_DEFINE_UNQUOTED(TROUSERS_LIB, ["$ac_trousers_lib"], [the location of the trousers library])
+AC_SUBST(TROUSERS_LIB)
+
included_libopts=no
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
LIBOPTS_CHECK([src/libopts])
@@ -916,7 +929,7 @@ AC_MSG_NOTICE([External hardware support:
Padlock accel: $use_padlock
getrandom variant: $enable_getrandom
PKCS#11 support: $with_p11_kit
- TPM support: $with_tpm
+ TPM support: $with_tpm ($ac_trousers_lib)
])
AC_MSG_NOTICE([Optional features: