summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-09-24 10:14:32 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-09-24 10:19:53 +0200
commit3f19ec230eddc091728168a33aa3da273063929c (patch)
treed5915ad4b38c8ffbef0769bc5cbc7f1dae4c27fd /configure.ac
parentee8c7e76eeb3f2be3cf5b112fa10a17e8441da4a (diff)
downloadgnutls-3f19ec230eddc091728168a33aa3da273063929c.tar.gz
enable gcc warnings by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 04f01b7480..6c468dd338 100644
--- a/configure.ac
+++ b/configure.ac
@@ -231,14 +231,14 @@ ggl_INIT
dnl GCC warnings to enable
AC_ARG_ENABLE([gcc-warnings],
- [AS_HELP_STRING([--enable-gcc-warnings],
- [turn on lots of GCC warnings (for developers)])],
+ [AS_HELP_STRING([--disable-gcc-warnings],
+ [turn off lots of GCC warnings (for developers)])],
[case $enableval in
yes|no) ;;
*) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
esac
gl_gcc_warnings=$enableval],
- [gl_gcc_warnings=no]
+ [gl_gcc_warnings=yes]
)
if test "$gl_gcc_warnings" = yes; then