summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Metzler <ametzler@bebt.de>2016-12-03 14:29:51 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2016-12-04 15:44:37 +0100
commitb0a103cb56d254d167a963bd955c42acb3155ce7 (patch)
tree451e7e6851363a0abb3604f51848020ed14f8989 /configure.ac
parent8c6d1278fea6b276989b0cbe40b6a5d1f447f51f (diff)
downloadgnutls-b0a103cb56d254d167a963bd955c42acb3155ce7.tar.gz
Prevent unwanted linkage to -lhogweed
Specify action-if-found for AC_CHECK_LIB when checking for !SuiteB curves to keep autoconf from adding -lhogweed to LIBS. This caused linkage of e.g. openssl wrapper and C++ library to -lhogweed. The issue only shows up if --disable-libdane is specified, since the dane autoconf test resets LIBS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4278d2ba94..2e518b9097 100644
--- a/configure.ac
+++ b/configure.ac
@@ -514,7 +514,7 @@ AC_ARG_ENABLE(non-suiteb-curves,
if test "$enable_non_suiteb" = "yes";then
dnl nettle_secp_192r1 is not really a function
- AC_CHECK_LIB(hogweed, nettle_secp_192r1,, enable_non_suiteb=no, [$HOGWEED_LIBS])
+ AC_CHECK_LIB(hogweed, nettle_secp_192r1, enable_non_suiteb=yes, enable_non_suiteb=no, [$HOGWEED_LIBS])
if test "$enable_non_suiteb" = "yes";then
AC_DEFINE([ENABLE_NON_SUITEB_CURVES], 1, [Enable all curves])