summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2018-03-02 09:38:55 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2018-03-02 09:46:27 +0100
commit8bc71dc0ed272c10b6430a678858b8e973828cf8 (patch)
treeba39ce59100efd126720c1a57439d2079555b488 /configure.ac
parent803f2e10748995c6386bb54cad4ceaca6bd1c1b3 (diff)
downloadgnutls-8bc71dc0ed272c10b6430a678858b8e973828cf8.tar.gz
tests: eliminated destructive teststmp-simplify-nettle-check
That adds a dependency to p11-kit 0.23.10 for the test suite. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 18be369534..e6b63a97d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,11 +255,6 @@ AC_ARG_ENABLE(tests,
enable_tests=$enableval, enable_tests=$enable_tools)
AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" != "no")
-AC_ARG_ENABLE(destructive-tests,
- AS_HELP_STRING([--enable-destructive-tests], [compile and run tests which touch outside gnutls' code boundary]),
- enable_destructive_tests=$enableval, enable_destructive_tests=no)
-AM_CONDITIONAL(ENABLE_DESTRUCTIVE_TESTS, test "$enable_destructive_tests" != "no")
-
AC_ARG_ENABLE(fuzzer-target,
AS_HELP_STRING([--enable-fuzzer-target], [make a library intended for testing - not production]),
enable_fuzzer_target=$enableval, enable_fuzzer_target=no)
@@ -616,6 +611,8 @@ if test "$with_p11_kit" != "no"; then
fi
fi
+AM_CONDITIONAL(P11KIT_0_23_10_API, ! $PKG_CONFIG --atleast-version=2.23.10 p11-kit)
+
AM_CONDITIONAL(ENABLE_PKCS11, test "$with_p11_kit" != "no")
AC_ARG_WITH(tpm,
@@ -974,7 +971,6 @@ AC_MSG_NOTICE([summary of build options:
Local unistring: ${included_unistring}
Use nettle-mini: ${mini_nettle}
Documentation: ${enable_doc} (manpages: ${enable_manpages})
- Destructive tests: ${enable_destructive_tests}
])
AC_MSG_NOTICE([External hardware support: