summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2016-07-09 14:52:42 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-07-13 10:41:46 +0200
commitc1663a74215f560def4f24492b881765b5b64fd5 (patch)
treea439b9a7ac0b31c5abc7d9b3d8e00abd4e4216df /configure.ac
parent7fccdcbeb508a3e9e271c1d882692672e0d21b86 (diff)
downloadgnutls-c1663a74215f560def4f24492b881765b5b64fd5.tar.gz
tests: added unit testing for DTLS sliding window implementation
This was taken from the unit testing of AF_KTLS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f2f08c0624..b8e6bbad6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -415,6 +415,9 @@ if [ test "$enable_fips" = "yes" ];then
fi
fi
+PKG_CHECK_MODULES(CMOCKA, cmocka, [with_cmocka=yes], [with_cmocka=no])
+AM_CONDITIONAL(HAVE_CMOCKA, test "$with_cmocka" != "no")
+
AC_ARG_WITH(idn, AS_HELP_STRING([--without-idn],
[disable support for libidn]),
try_libidn="$withval",