summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-01-27 10:21:56 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2017-03-06 22:24:33 +0100
commit1677f1ac06beecb2fb23f0f49d89260f86131a5c (patch)
tree66f93eaf204c51510629188c6557f12473671d2b /configure.ac
parente8ff21bd972097cf4163ee710bbfc2817dc45d98 (diff)
downloadgnutls-1677f1ac06beecb2fb23f0f49d89260f86131a5c.tar.gz
Use a thread local random generator.
This allows accessing the per-thread random generator in a lock-free way, at the cost of additional memory per thread. The default random generator imposes around 640 bytes per thread on 64-bit architectures. Resolves: #141 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5779d2d584..23cbd5b7f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,6 +192,9 @@ dnl Need netinet/tcp.h for TCP_FASTOPEN
AC_CHECK_HEADERS([netinet/tcp.h])
AC_CHECK_HEADERS([stdatomic.h])
+dnl We use its presence to detect C11 threads
+AC_CHECK_HEADERS([threads.h])
+
AC_ARG_ENABLE(padlock,
AS_HELP_STRING([--disable-padlock], [unconditionally disable padlock acceleration]),
use_padlock=$enableval)