summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim Rühsen <tim.ruehsen@gmx.de>2018-11-16 16:20:17 +0100
committerTim Rühsen <tim.ruehsen@gmx.de>2018-12-18 11:26:57 +0100
commit9f564d2286a8a484c1b1f45fe4f6d988d6652878 (patch)
tree2a9de034c2056d6e25d1c42e5d790ff94dd69bd3 /configure.ac
parentd79dbf99e555abdcc79f1253976189efa892c0fc (diff)
downloadgnutls-9f564d2286a8a484c1b1f45fe4f6d988d6652878.tar.gz
tests/cert-tests/certtool: SKIP if --disable-bash-tests was given
Signed-off-by: Tim Rühsen <tim.ruehsen@gmx.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d44791bd91..21ab6bbe9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,11 @@ fi
AX_CODE_COVERAGE
AM_MAINTAINER_MODE([enable])
+AC_ARG_ENABLE(bash-tests,
+ AS_HELP_STRING([--disable-bash-tests], [skip some tests that badly need bash]),
+ enable_bash_tests=$enableval, enable_bash_tests=yes)
+AM_CONDITIONAL(DISABLE_BASH_TESTS, test "$enable_bash_tests" != "yes")
+
AC_ARG_ENABLE(doc,
AS_HELP_STRING([--disable-doc], [don't generate any documentation]),
enable_doc=$enableval, enable_doc=yes)