summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-11-12 13:41:19 +0100
committerDaiki Ueno <dueno@redhat.com>2018-11-13 14:57:34 +0100
commit78895715dba681d25a47e5da369d3eb20fcf08ed (patch)
tree12231a7bb5cd5946762044c52de66ac3fa65964f /configure.ac
parenteac0905a095a13a4652a9ebbf2df0c3e1f867cc5 (diff)
downloadgnutls-78895715dba681d25a47e5da369d3eb20fcf08ed.tar.gz
build: remove autogen .bak files from the repository
While the .bak files are necessary for not requiring autogen on deployment environment, they are not needed for development and may cause conflict when other developers use different version of autogen. This removes those files from the repository and require autogen at make dist time. Signed-off-by: Daiki Ueno <dueno@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 5e915eac53..7deb6b389b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -714,7 +714,6 @@ AC_SUBST(TROUSERS_LIB)
AM_MISSING_PROG([AUTOGEN], [autogen])
included_libopts=no
-create_libopts_links=no
if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
AC_CHECK_PROGS([autogen], [autogen])
@@ -729,7 +728,6 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
LIBOPTS_CHECK([src/libopts])
if test "$NEED_LIBOPTS_DIR" = "true";then
dnl replace libopts-generated files with distributed backups, if present
- create_libopts_links=yes
included_libopts=yes
fi
else
@@ -950,15 +948,6 @@ dnl Some variables needed in makefiles
YEAR=`date +%Y`
AC_SUBST([YEAR], $YEAR)
-for i in ${srcdir}/src/*-args.c.bak ${srcdir}/src/*-args.h.bak; do
- nam=$(basename $i|sed 's/.bak//g')
- if test "$create_libopts_links" = "yes";then
- rm -f "src/$nam.stamp"
- rm -f "src/$nam"
- AC_CONFIG_LINKS([src/$nam:$i])
- fi
-done
-
AC_CONFIG_FILES([guile/pre-inst-guile], [chmod +x guile/pre-inst-guile])
AC_CONFIG_FILES([
Makefile