summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2018-10-24 13:04:22 -0400
committerSimo Sorce <simo@redhat.com>2018-10-24 17:56:56 -0400
commit2e30163b1fda16ae1e7373458f1cbbce96fe4a6b (patch)
treee1afd5393cccab0f9d583a7e24904b4faa83a89e /configure.ac
parent940143cccea91fdc41f9a052ee2b64ecbd3a5dac (diff)
downloadgnutls-2e30163b1fda16ae1e7373458f1cbbce96fe4a6b.tar.gz
Vendor in CFB8 functionality from Nettle
If nettle's CFB8 is not available, use a vendored in version from master. This is necessary as long as we need to link against 3.4 for ABI compatibility reasons. Signed-off-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 95c756e8bd..7b50f548d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -559,6 +559,12 @@ if test "$enable_non_suiteb" = "yes";then
fi
AM_CONDITIONAL(ENABLE_NON_SUITEB_CURVES, test "$enable_non_suiteb" = "yes")
+# Check if nettle has CFB8 support
+save_LIBS=$LIBS
+LIBS="$LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS(nettle_cfb8_encrypt)
+LIBS=$save_LIBS
+
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],