summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2018-10-19 15:53:27 -0400
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2019-03-29 20:50:58 +0100
commitea46e149b69cf1c4b963e6d156a6b3e38d710894 (patch)
tree46cfe51b9e4deb4c976594a9fe1602f7fd08aff7 /configure.ac
parentf2a6431b6e709f2287aca6075580313800828ad1 (diff)
downloadgnutls-ea46e149b69cf1c4b963e6d156a6b3e38d710894.tar.gz
Vendor in XTS functionality from Nettle
If nettle's XTS is not available, use a vendored in version from master. This is necessary as long as we need to link against 3.4 for ABI compatibility reasons. Signed-off-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b686726d1b..f9d40b4ea2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -563,6 +563,13 @@ LIBS="$LIBS $NETTLE_LIBS"
AC_CHECK_FUNCS(nettle_cmac128_update)
LIBS=$save_LIBS
+# Check if nettle has XTS support
+save_LIBS=$LIBS
+LIBS="$LIBS $NETTLE_LIBS"
+AC_CHECK_FUNCS(xts_encrypt_message)
+LIBS=$save_LIBS
+
+
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],