summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2017-05-20 20:41:30 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2017-05-20 20:41:43 +0200
commit6ac700ea24bb1fa29671714340068c3787012e28 (patch)
tree257699e78ae5234eab15ca353db3f579839bfa2f /configure.ac
parent6ce8416ff7b8005dc980b030ac858dca676dd6ca (diff)
downloadgnutls-6ac700ea24bb1fa29671714340068c3787012e28.tar.gz
sysrng-linux: improved detection of getrandom()tmp-remove-arcfour-from-benchmarks
The getrandom() call is defined in sys/random.h. Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a02579afff..a322e625b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,11 +215,11 @@ dnl check for getrandom()
rnd_variant="auto-detect"
AC_MSG_CHECKING([for getrandom])
AC_LINK_IFELSE([AC_LANG_PROGRAM([
- #include <linux/random.h>],[
+ #include <sys/random.h>],[
getrandom(0, 0, 0);
])],
[AC_MSG_RESULT(yes)
- AC_DEFINE([HAVE_LINUX_GETRANDOM], 1, [Enable the Linux getrandom function])
+ AC_DEFINE([HAVE_GETRANDOM], 1, [Enable the Linux getrandom function])
rnd_variant=getrandom],
[AC_MSG_RESULT(no)])