summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-23 10:12:23 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-11-23 10:51:16 +0100
commitf4b363f163577c1f3f5a20ea7dadf3077a64d3ea (patch)
treea61dc086ea2cde433d2a182cd625afa6fd6453b3 /configure.ac
parentc2dd659b41aa8750aa7787551f6c6605d7846a06 (diff)
downloadgnutls-f4b363f163577c1f3f5a20ea7dadf3077a64d3ea.tar.gz
Corrected check of usage of local libopts when autogen isn't present
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6b582e8670..39278d83b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,7 +50,7 @@ if test x"$AUTOGEN" = "x/bin/true"; then
***
*** autogen not found. Will not link against libopts.
*** ]])
-NEED_LIBOPTS_DIR=true
+enable_local_libopts=yes
fi
# For includes/gnutls/gnutls.h.in.
@@ -347,9 +347,8 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
-ac_enable_local_libopts=yes
LIBOPTS_CHECK([src/libopts])
-if test "$NEED_LIBOPTS_DIR" != "true";then
+if test "$NEED_LIBOPTS_DIR" == "true";then
dnl delete libopts-generated files
for i in ${srcdir}/src/*-args.c.bak ${srcdir}/src/*-args.h.bak; do
nam=`echo $i|sed 's/.bak//g'`
@@ -358,8 +357,11 @@ if test "$NEED_LIBOPTS_DIR" != "true";then
fi
done
AC_SUBST([AUTOGEN], [/bin/true])
- ac_enable_local_libopts=no
+ enable_local_libopts=yes
+else
+ enable_local_libopts=no
fi
+AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
AC_CHECK_TYPE(ssize_t,
[
@@ -717,7 +719,7 @@ if features are disabled)
AC_MSG_NOTICE([Optional applications:
crywrap app: $libidn
- local libopts: ${ac_enable_local_libopts}
+ local libopts: ${enable_local_libopts}
local libtasn1: ${included_libtasn1}
])