summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-13 14:20:50 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-13 14:27:36 +0100
commitd33e041f6fe4aa21018775508f536d51ab0244e0 (patch)
tree6adb3c017570635eeb37de19b0a83fee73518c8a /configure.ac
parentd46f4091f99cb163b1b46f8630c7827b231c6885 (diff)
downloadgnutls-d33e041f6fe4aa21018775508f536d51ab0244e0.tar.gz
print whether the local libopts or libtasn1 are being used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8955b03b61..2979d7146a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,7 @@ fi
AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
+ac_enable_local_libopts=yes
LIBOPTS_CHECK([src/libopts])
if test "$NEED_LIBOPTS_DIR" != "true";then
dnl delete libopts-generated files
@@ -354,6 +355,7 @@ if test "$NEED_LIBOPTS_DIR" != "true";then
fi
done
AC_SUBST([AUTOGEN], [/bin/true])
+ ac_enable_local_libopts=no
fi
AC_CHECK_TYPE(ssize_t,
@@ -711,7 +713,8 @@ if features are disabled)
AC_MSG_NOTICE([Optional applications:
crywrap app: $libidn
- libopts flags: ${LIBOPTS_LDADD}
+ local libopts: ${ac_enable_local_libopts}
+ local libtasn1: ${included_libtasn1}
])
AC_MSG_NOTICE([Optional libraries: