summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stefw@redhat.com>2013-05-21 12:34:29 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-10-31 20:51:39 +0100
commit8131d73270eac89e4eec69b2228156b02dd5e8de (patch)
treeb01d8395f72e7e79fe40980bad12dbf9e9ed72b1 /configure.ac
parent2ba1cf71d66a9902bdedc17d628995ce12002a9b (diff)
downloadgnutls-8131d73270eac89e4eec69b2228156b02dd5e8de.tar.gz
[PATCH] Update to use new p11-kit APIs
Some of the older APIs were deprecated in order to support multiple callers of the same PKCS#11 module correctly. This increases the necessary p11-kit to 0.19.1 or later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3e7ea9a780..6b0b290d2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -281,11 +281,12 @@ AC_DEFINE_UNQUOTED([UNBOUND_ROOT_KEY_FILE],
["$unbound_root_key_file"], [The DNSSEC root key file])
dnl Check for p11-kit
+P11_KIT_MINIMUM=0.19.1
AC_ARG_WITH(p11-kit,
AS_HELP_STRING([--without-p11-kit],
[Build without p11-kit and PKCS#11 support]))
if test "$with_p11_kit" != "no"; then
- PKG_CHECK_MODULES(P11_KIT, [p11-kit-1 >= 0.11], [with_p11_kit=yes], [with_p11_kit=no])
+ PKG_CHECK_MODULES(P11_KIT, [p11-kit-1 >= $P11_KIT_MINIMUM], [with_p11_kit=yes], [with_p11_kit=no])
if test "$with_p11_kit" != "no";then
AC_DEFINE([ENABLE_PKCS11], 1, [Build PKCS#11 support])
if test "x$GNUTLS_REQUIRES_PRIVATE" = "x"; then
@@ -297,7 +298,7 @@ if test "$with_p11_kit" != "no"; then
with_p11_kit=no
AC_MSG_WARN([[
***
-*** p11-kit was not found. PKCS #11 support will be disabled.
+*** p11-kit >= $P11_KIT_MINIMUM was not found. PKCS #11 support will be disabled.
*** You may get it from http://p11-glue.freedesktop.org/p11-kit.html
*** ]])
fi