summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-26 17:19:43 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2013-11-26 17:21:15 +0100
commit11c6e66f570a6d6ed3baabe3c7924ef29fe47ad0 (patch)
treec1cfb6f0d917df1de56f1858fa59ccc00391eae6 /configure.ac
parent277bc208ebdf227940ea7418cf14fb286f2056ad (diff)
downloadgnutls-11c6e66f570a6d6ed3baabe3c7924ef29fe47ad0.tar.gz
Do not link gnutls against librt unlress it is really necessary.
Conflicts: configure.ac lib/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0bfd6454a5..bf7f8dac1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,6 +232,7 @@ fi
if test "$ac_cv_func_nanosleep" != "yes";then
AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>], [nanosleep (0, 0);])
+ gnutls_needs_librt=yes
fi
ac_have_unicode=no
@@ -552,6 +553,7 @@ LIBGNUTLS_CFLAGS="-I${includedir}"
AC_SUBST(LIBGNUTLS_LIBS)
AC_SUBST(LIBGNUTLS_CFLAGS)
+AM_CONDITIONAL(NEEDS_LIBRT, test "$gnutls_needs_librt" = "yes")
AC_DEFINE([GNUTLS_COMPAT_H], 1, [Make sure we don't use old features in code.])
AC_DEFINE([GNUTLS_INTERNAL_BUILD], 1, [We allow temporarily usage of deprecated functions - until they are removed.])