summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-12-14 15:20:25 -0300
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-12-15 11:56:21 +0100
commita0b77271d9dc4a1e27f4ee3adff28c37b43a236e (patch)
tree91cc3325a0cd7f51c9180cc3dffb49a3cea0ef4d /configure.ac
parentf3703e4a72c6e41e6026017a14e28b3372d53d60 (diff)
downloadgnutls-a0b77271d9dc4a1e27f4ee3adff28c37b43a236e.tar.gz
configure: really make --disable-crywrap work
The crywrap variable is set regardless of the state of enable_crywrap, hence --disable-crywrap never works. Just put the tests for crywrap deps inside the enable_crywrap conditional. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e1d1df01d3..efacc30092 100644
--- a/configure.ac
+++ b/configure.ac
@@ -836,11 +836,10 @@ AC_ARG_ENABLE(crywrap,
if test "x$enable_crywrap" != "xno" ; then
- AC_CHECK_FUNCS([argp_usage],[ac_argp=yes],[ac_argp=no])
- fi
-
- if test "$ac_cv_func_daemon" != "no" && test "$ac_argp" != "no" && test "$with_libidn" != "no";then
- crywrap=yes
+ AC_CHECK_FUNCS([argp_usage],[ac_argp=yes],[ac_argp=no])
+ if test "$ac_cv_func_daemon" != "no" && test "$ac_argp" != "no" && test "$with_libidn" != "no";then
+ crywrap=yes
+ fi
fi
fi