summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2016-10-11 21:33:24 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-10-12 07:56:43 +0200
commit7948cc8964cceb4bd2711caca03a1a159b8e2657 (patch)
tree543c2720a94b3a0fdaa3db3055cd2bfd8d6fab73 /configure.ac
parentc3453c0407ce97fda28d5e2998eb4f10fd3a59e3 (diff)
downloadgnutls-7948cc8964cceb4bd2711caca03a1a159b8e2657.tar.gz
configure: automatically disable non-suiteb curves
That is, if the installed nettle doesn't provide the nettle_secp_192r1 symbol.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 137ed37009..2e51075915 100644
--- a/configure.ac
+++ b/configure.ac
@@ -500,8 +500,14 @@ AM_CONDITIONAL(HAVE_BUGGY_LIBIDN, test "$with_buggy_libidn" = "yes")
AC_ARG_ENABLE(non-suiteb-curves,
AS_HELP_STRING([--disable-non-suiteb-curves], [disable curves not in SuiteB]),
enable_non_suiteb=$enableval, enable_non_suiteb=yes)
-if [ test "$enable_non_suiteb" = "yes" ];then
- AC_DEFINE([ENABLE_NON_SUITEB_CURVES], 1, [Enable all curves])
+
+if test "$enable_non_suiteb" = "yes";then
+ dnl nettle_secp_192r1 is not really a function
+ AC_CHECK_LIB(hogweed, nettle_secp_192r1,, enable_non_suiteb=no, [$HOGWEED_LIBS])
+
+ if test "$enable_non_suiteb" = "yes";then
+ AC_DEFINE([ENABLE_NON_SUITEB_CURVES], 1, [Enable all curves])
+ fi
fi
AM_CONDITIONAL(ENABLE_NON_SUITEB_CURVES, test "$enable_non_suiteb" = "yes")