summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-07-29 10:22:43 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-07-29 12:55:54 +0200
commitec83c49234a81531ad123e831df2c49a1ac6ebe5 (patch)
tree65749fabbf355d785552805be67828330b99745a /configure.ac
parent7a76e94f7c4d1facc8e04dc6158f1dbfd6265a0e (diff)
downloadgnutls-ec83c49234a81531ad123e831df2c49a1ac6ebe5.tar.gz
Use pthread_atfork() and variants to detect fork
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af38fa5e29..eef6c9fefc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -149,6 +149,8 @@ dnl Check clock_gettime and pthread_mutex_lock in libc (avoid linking to other l
AC_CHECK_FUNCS([fork inet_ntop inet_pton getrusage getpwuid_r nanosleep daemon getpid clock_gettime iconv localtime vasprintf],,)
AM_CONDITIONAL(HAVE_FORK, test "$ac_cv_func_fork" != "no")
+AC_CHECK_FUNCS([pthread_atfork __register_atfork],,)
+
AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>
#include <signal.h>
], [timer_create (0,0,0);])