summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-09-13 13:06:33 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-09-13 13:06:33 +0200
commit7fb0624d1cbace4c94ce84eb9903a974e6446864 (patch)
tree8e89c09b23bca08ceeb6fb6f38e0f6dbbe52b88a /configure.ac
parent27526df9a21d4adf6eaa5392ceca8a28f9674b9d (diff)
downloadgnutls-7fb0624d1cbace4c94ce84eb9903a974e6446864.tar.gz
simulate pkcs11x.h when it doesn't exist
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65eade2d7b..08d9c72a5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ AC_MSG_RESULT([***
])
dnl Checks for programs.
+PKG_PROG_PKG_CONFIG
AC_PROG_CC
gl_EARLY
ggl_EARLY
@@ -411,6 +412,7 @@ system_priority_file="/etc/gnutls/default-priorities"
AC_DEFINE_UNQUOTED([SYSTEM_PRIORITY_FILE],
["$system_priority_file"], [The system priority file])
+
dnl Check for p11-kit
P11_KIT_MINIMUM=0.20.0
AC_ARG_WITH(p11-kit,
@@ -425,6 +427,9 @@ if test "$with_p11_kit" != "no"; then
else
GNUTLS_REQUIRES_PRIVATE="${GNUTLS_REQUIRES_PRIVATE}, p11-kit-1"
fi
+ if $PKG_CONFIG --atleast-version=2.20.6 p11-kit; then
+ AC_DEFINE([HAVE_PKCS11X_H], 1, [There is p11-kit/pkcs11x.h])
+ fi
else
with_p11_kit=no
AC_MSG_WARN([[