summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2014-04-09 14:11:00 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2014-04-09 14:11:00 +0200
commit49043202dde3fb7e0f3b48b9e7288e930ef81d1c (patch)
treecc1e2ddd422a905b6edf20bc340bcdd44788a0dd /configure.ac
parente068b53b8fb7ec92ad101998bed01165c25d554e (diff)
downloadgnutls-49043202dde3fb7e0f3b48b9e7288e930ef81d1c.tar.gz
corrected configure test for pthread_mutex_lock
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6025d9a89d..9440446c4b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -153,8 +153,8 @@ AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>
], [timer_create (0,0,0);])
if test "$have_win" != "yes";then
+ AC_CHECK_FUNCS([pthread_mutex_lock],,)
if test "$ac_cv_func_pthread_mutex_lock" != "yes";then
- AC_CHECK_FUNCS([pthread_mutex_lock],,)
AC_LIB_HAVE_LINKFLAGS(pthread,, [#include <pthread.h>], [pthread_mutex_lock (0);])
fi
fi