summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-12-14 15:20:25 -0300
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-12-15 12:11:18 +0100
commit47e6d14df3e86eb6fd55b15518ac44356abc445c (patch)
treeae4de166c82a5250452e3659b23d4b9a6d76a8e6 /configure.ac
parent1b3b3358da54e3dc8f49064eb5fbee7b866bb6b2 (diff)
downloadgnutls-47e6d14df3e86eb6fd55b15518ac44356abc445c.tar.gz
configure: really make --disable-crywrap work
The crywrap variable is set regardless of the state of enable_crywrap, hence --disable-crywrap never works. Just put the tests for crywrap deps inside the enable_crywrap conditional. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e6342365c9..931e487b9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -821,11 +821,10 @@ AC_ARG_ENABLE(crywrap,
if test "x$enable_crywrap" != "xno" ; then
- AC_CHECK_FUNCS([argp_usage],[ac_argp=yes],[ac_argp=no])
- fi
-
- if test "$ac_cv_func_daemon" != "no" && test "$ac_argp" != "no" && test "$with_libidn" != "no";then
- crywrap=yes
+ AC_CHECK_FUNCS([argp_usage],[ac_argp=yes],[ac_argp=no])
+ if test "$ac_cv_func_daemon" != "no" && test "$ac_argp" != "no" && test "$with_libidn" != "no";then
+ crywrap=yes
+ fi
fi
fi