summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2014-10-26 00:09:34 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2014-10-26 00:09:34 +0200
commit0b5c84761883565c303a5918ad2bc5cd26b91e7e (patch)
tree6fe1fe4ebcbb0c2c6c8a2422d2b382002da484fd /configure.ac
parent1bf16e8335bf34cbdf7095be576cc6d36aa3038a (diff)
downloadgnutls-0b5c84761883565c303a5918ad2bc5cd26b91e7e.tar.gz
disable hardware acceleration by default in solaris
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 44163be855..db286f700a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,7 @@ AM_CONDITIONAL(ENABLE_CXX, test "$use_cxx" != "no")
AM_CONDITIONAL(WANT_TEST_SUITE, [test -f tests/suite/mini-eagain2.c])
dnl Detect windows build
+use_accel=yes
case "$host" in
*mingw32* | *mingw64*)
have_win=yes
@@ -86,6 +87,14 @@ case "$host" in
*darwin*)
have_macosx=yes
;;
+ *solaris*)
+ use_accel=no
+ AC_MSG_WARN([[
+***
+*** In solaris hardware acceleration is disabled by default due to issues
+*** with the assembler. Use --enable-hardware-acceleration to enable it.
+*** ]])
+ ;;
*)
have_elf=yes
;;
@@ -98,7 +107,7 @@ AM_CONDITIONAL(ELF, test "$have_elf" = yes)
dnl Hardware Acceleration
AC_ARG_ENABLE(hardware-acceleration,
AS_HELP_STRING([--disable-hardware-acceleration], [unconditionally disable hardware acceleration]),
- use_accel=$enableval, use_accel=yes)
+ use_accel=$enableval)
hw_accel=none