summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-01-21 08:51:07 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-01-21 09:38:35 +0100
commit164e2fdb40506e85029323aeb3d2e8ab0e0c4c46 (patch)
treed5dffc26bedfb9a50c7fd8c7c264e4ff0cb8847e /configure.ac
parent49974f03c66ad820de03246e128b59b4d2cedcde (diff)
downloadgnutls-164e2fdb40506e85029323aeb3d2e8ab0e0c4c46.tar.gz
Added configure flag --with-arcfour128
This flag will re-enable ARCFOUR in the priority strings by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20f7744548..d008833651 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,6 +350,14 @@ if [ test "$enable_self_checks" = "yes" ];then
AC_DEFINE([ENABLE_SELF_CHECKS], 1, [Self checks are included in the library])
fi
+AC_ARG_WITH(arcfour128,
+ AS_HELP_STRING([--with-arcfour128], [include ARCFOUR128 in priority strings]),
+ enable_arcfour=$withval, enable_arcfour=no)
+if [ test "$enable_arcfour" = "yes" ];then
+ AC_DEFINE([ENABLE_ARCFOUR128], 1, [Enable ARCFOUR128])
+fi
+AM_CONDITIONAL(ENABLE_ARCFOUR128, test "$enable_arcfour" = "yes")
+
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],