summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2013-07-29 09:55:42 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2013-07-29 10:05:51 +0200
commitab9a13d2e496b6ce04e655afc03b355903f09fc0 (patch)
treea2b6cd5bdb75e48626b1613dbda0ed34c23122a8 /configure.ac
parentd53d8cef9d41f5839714ab6f7297ceb76cbe1cd4 (diff)
downloadgnutls-ab9a13d2e496b6ce04e655afc03b355903f09fc0.tar.gz
Correctly report unicode status in win32 API
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 613e32ed6b..645940300a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,7 @@ if test "$ac_cv_func_nanosleep" != "yes";then
AC_LIB_HAVE_LINKFLAGS(rt,, [#include <time.h>], [nanosleep (0, 0);])
fi
+ac_have_unicode=no
if test "$ac_cv_func_iconv" != "yes";then
AC_LIB_HAVE_LINKFLAGS(iconv,, [#include <iconv.h>], [iconv (0, 0, 0, 0, 0);])
if test "$HAVE_LIBICONV" = "yes";then
@@ -226,6 +227,12 @@ else
ac_have_unicode=yes
fi
+if test "$ac_have_unicode" != "yes";then
+ if test "$have_win" = "yes";then
+ ac_have_unicode=yes
+ fi
+fi
+
AC_MSG_CHECKING([whether to build libdane])
AC_ARG_ENABLE(libdane,
AS_HELP_STRING([--disable-libdane],