summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-07-09 22:50:11 +0200
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-07-09 22:50:15 +0200
commit2bc11dad0b48faf3b5b6004deaed12b3d9008485 (patch)
treef67c9e1c3610c8b9d1eaad000579def4f73b86ee /configure.ac
parent03fffd0f1fb4299ebec2c374bff81d26a91ce7be (diff)
downloadgnutls-2bc11dad0b48faf3b5b6004deaed12b3d9008485.tar.gz
tests: don't run certtool-utf8 when libidn is 1.30 or less
This avoids test suite failures due to libidn.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a02dcb080..a1937c11f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,6 +376,10 @@ AC_ARG_WITH(idn, AS_HELP_STRING([--without-idn],
if test "$try_libidn" = yes;then
PKG_CHECK_MODULES(LIBIDN, libidn >= 0.5.6, [with_libidn=yes], [with_libidn=no])
if test "$with_libidn" != "no";then
+ if ! $PKG_CONFIG --atleast-version=1.31 libidn; then
+ with_buggy_libidn=yes
+ fi
+
AC_DEFINE([HAVE_LIBIDN], 1, [Build IDNA support])
if test "x$GNUTLS_REQUIRES_PRIVATE" = "x"; then
GNUTLS_REQUIRES_PRIVATE="Requires.private: libidn"
@@ -394,6 +398,7 @@ else
fi
AM_CONDITIONAL(HAVE_LIBIDN, test "$with_libidn" != "no")
+AM_CONDITIONAL(HAVE_BUGGY_LIBIDN, test "$with_buggy_libidn" = "yes")
AC_ARG_ENABLE(non-suiteb-curves,
AS_HELP_STRING([--disable-non-suiteb-curves], [disable curves not in SuiteB]),