summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <ueno@gnu.org>2022-04-08 10:23:51 +0200
committerDaiki Ueno <ueno@gnu.org>2022-04-15 09:18:33 +0200
commit859e3f57b6248d13c8cc84008e9cdf2164877b95 (patch)
treeb8d47860d36c3b450a776a77a2ef3e80c3e44791 /Makefile.am
parent94856a76a47d059fecbc17d2ec07fb847889e1d8 (diff)
downloadgnutls-859e3f57b6248d13c8cc84008e9cdf2164877b95.tar.gz
cligen: update git submodule
This also reverts commit fd0e28a3 and changes how the cligen python files are included in the distribution. Signed-off-by: Daiki Ueno <ueno@gnu.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1cdbc1fae2..0f2ccdff0a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,7 +28,7 @@ DISTCHECK_CONFIGURE_FLAGS = \
--with-guile-extension-dir='$$(libdir)/guile/$$(GUILE_EFFECTIVE_VERSION)/extensions' \
AUTOGEN=false
-SUBDIRS = gl lib extra python
+SUBDIRS = gl lib extra
if ENABLE_DANE
SUBDIRS += libdane
@@ -202,3 +202,6 @@ dist-hook:
touch -c $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info
.PHONY: abi-check abi-dump-versioned abi-dump-latest pic-check symbol-check local-code-coverage-output files-update AUTHORS
+
+include $(top_srcdir)/cligen/cligen.mk
+noinst_PYTHON = $(cligen_sources)