summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2016-01-07 14:14:21 +0100
committerNikos Mavrogiannopoulos <nmav@redhat.com>2016-01-07 14:14:43 +0100
commitd188c580b287648fb5bf9aefcc735ea3e6088d25 (patch)
tree766b3ca96bdb54501927c61fc4e7e6971559c32f /Makefile.am
parent735dbde324be6c8785a3dea5f09c82b6a8ad298b (diff)
downloadgnutls-d188c580b287648fb5bf9aefcc735ea3e6088d25.tar.gz
symbols.last: don't include internal symbols into exported list
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f39916fca5..7c19ccd2b1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -67,7 +67,7 @@ dist-hook:
@echo "symbols added or removed are correct and copy symbols.last.tmp as"
@echo "symbols.last"
@echo "*****************************************************************"
- objdump -T $(srcdir)/lib/.libs/libgnutls.so.30 | grep -v ' \*UND\*' | awk '{print $$7 "@" $$6;}' | sort -u >symbols.last.tmp
+ objdump -T $(srcdir)/lib/.libs/libgnutls.so.30 | grep -v ' \*UND\*' | awk '{print $$7 "@" $$6;}' | grep -v GNUTLS_FIPS140 | grep -v GNUTLS_PRIVATE | sort -u >symbols.last.tmp
diff -u symbols.last symbols.last.tmp >/dev/null 2>&1
rm -f symbols.last.tmp
abi-compliance-checker -abi -lib gnutls -old devel/abi3.4.xml -new devel/abi.xml