summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Persch <chpe@gnome.org>2014-05-22 13:50:16 +0200
committerChristian Persch <chpe@gnome.org>2014-05-22 13:52:03 +0200
commitc38f44dafea624ca656d3700e0f4b0c0a259856e (patch)
tree1e1a894953f0782876f67ca18aef8883a8da728a /configure.ac
parent174428ceafa642747400c5497dcfe207ec928db1 (diff)
downloadvte-c38f44dafea624ca656d3700e0f4b0c0a259856e.tar.gz
build: Don't enable pty helper by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index de4aa8e2..b78ff0e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -238,7 +238,12 @@ AC_CHECK_TYPES(wint_t, AC_DEFINE(HAVE_WINT_T, , [Defined when the wint_t type is
# GNOME PTY Helper
################################################################################
-AC_ARG_ENABLE(gnome-pty-helper, [AS_HELP_STRING(--enable-gnome-pty-helper,Build a setuid helper for opening ptys [default=yes])], enable_gnome_pty_helper="$enableval", enable_gnome_pty_helper=yes)
+AC_MSG_CHECKING([whether to build the PTY helper binary])
+AC_ARG_ENABLE(gnome-pty-helper,
+ [AS_HELP_STRING([--disable-gnome-pty-helper],
+ [Build a setuid helper for opening ptys])],
+ [],[enable_gnome_pty_helper=no])
+AC_MSG_RESULT([$enable_gnome_pty_helper])
if test "$enable_gnome_pty_helper" != no; then
AC_DEFINE(VTE_USE_GNOME_PTY_HELPER,1,[Define if you intend to use gnome-pty-helper.])
AC_CONFIG_SUBDIRS(gnome-pty-helper)
@@ -375,4 +380,5 @@ Configuration for libvte $VERSION for gtk+-$GTK_API_VERSION
Introspection: $enable_introspection
Vala bindings: $enable_vala
Test application: $enable_test_application
+ PTY helper: $enable_gnome_pty_helper
EOF