summaryrefslogtreecommitdiff
path: root/src/tracker/meson.build
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2021-08-12 15:30:16 +0200
committerCarlos Garnacho <carlosg@gnome.org>2023-05-14 00:30:57 +0200
commit688b1600a65e77aad273800f705281e9ed25e648 (patch)
tree5049ba0bd8163cf0bd092f9d07972332b481fd1c /src/tracker/meson.build
parent8eeaa1595d9e7c9d280e48292cacc2ff477c6ca7 (diff)
downloadtracker-688b1600a65e77aad273800f705281e9ed25e648.tar.gz
cli: Add "shell" subcommandwip/carlosg/sparql-shell
As the command says, this creates a "shell" connecting to a given SPARQL endpoint (by default, in-memory DB), so that multiple queries can be executed on it. This shell is rather basic, allowing to either quit (via Ctrl-Q or 3 Ctrl-C presses), or execute the given SPARQL query (via Ctrl-X). When displaying a cursor content, output is redirected to a pager (by default "less") for display purposes, returning back to the SPARQL shell after quitting. It also has some rudimentary history support, allowing the use of PgUp and PgDown to navigate through the prior command list. This list only holds up for the running session though and is not saved in disk. The editor handles multiline and text that is larger than the available screen size, and handles the minimal set of keys that is expected for navigation. When dealing with errors, the full error message is displayed, and the editor cursor is moved to the location of the syntax error (if any, and available).
Diffstat (limited to 'src/tracker/meson.build')
-rw-r--r--src/tracker/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/tracker/meson.build b/src/tracker/meson.build
index caaa4b3a3..3f64f0180 100644
--- a/src/tracker/meson.build
+++ b/src/tracker/meson.build
@@ -3,6 +3,7 @@ modules = [
'export',
'help',
'import',
+ 'shell',
'sparql',
'sql',
]