summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCarlos Garnacho <carlosg@gnome.org>2016-12-08 14:32:10 +0100
committerCarlos Garnacho <carlosg@gnome.org>2016-12-08 14:37:39 +0100
commit397e1e00c455babaa1d6e65f04e1f7145020731e (patch)
treefcd82e1566f911c17732f0fc9675ba848b873857 /configure.ac
parent5b4132cd2f8528800c187df20336b67063adf2e3 (diff)
downloadtracker-397e1e00c455babaa1d6e65f04e1f7145020731e.tar.gz
configure: Make seccomp support mandatory
This is something we can do on master, older stable releases will have to stick to optional support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1a99ebdf..908777e6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2614,6 +2614,8 @@ if test "$have_libseccomp" = "yes"; then
LIBTRACKER_COMMON_LIBS="$LIBTRACKER_COMMON_LIBS $LIBSECCOMP_LIBS"
LIBTRACKER_COMMON_CFLAGS="$LIBTRACKER_COMMON_CFLAGS $LIBSECCOMP_CFLAGS"
AC_DEFINE(HAVE_LIBSECCOMP, [], [Define if we have libseccomp])
+else
+ AC_MSG_ERROR([Libseccomp is mandatory for sandboxed metadata extraction])
fi
##################################################################