summaryrefslogtreecommitdiff
path: root/tool/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tool/meson.build')
-rw-r--r--tool/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/tool/meson.build b/tool/meson.build
index 686cf24..1bf9a84 100644
--- a/tool/meson.build
+++ b/tool/meson.build
@@ -9,3 +9,9 @@ secret_tool = executable('secret-tool',
c_args: libsecret_cflags,
install: true,
)
+
+if with_gcrypt and host_machine.system() != 'windows'
+ test('test-secret-tool.sh',
+ find_program('test-secret-tool.sh'),
+ env: test_env)
+endif