summaryrefslogtreecommitdiff
path: root/docs/man/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'docs/man/meson.build')
-rw-r--r--docs/man/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/docs/man/meson.build b/docs/man/meson.build
new file mode 100644
index 0000000..37cabc4
--- /dev/null
+++ b/docs/man/meson.build
@@ -0,0 +1,18 @@
+secret_tool_man = custom_target('secret-tool.1',
+ input: 'secret-tool.xml',
+ output: 'secret-tool.1',
+ command: [ find_program('xsltproc'),
+ '-o', '@OUTPUT@',
+ '--nonet',
+ '--stringparam', 'man.output.quietly', '1',
+ '--stringparam', 'man.funcsynopsis.style', 'ansi',
+ '--stringparam', 'man.th.extra1.suppress', '1',
+ '--stringparam', 'man.authors.section.enabled', '0',
+ '--stringparam', 'man.copyright.section.enabled', '0',
+ 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ '@INPUT@',
+ ],
+ build_by_default: true,
+ install: true,
+ install_dir: join_paths(libsecret_prefix, get_option('mandir'), 'man1'),
+)