summaryrefslogtreecommitdiff
path: root/libsecret/Makefile.am
diff options
context:
space:
mode:
authorKouhei Sutou <kou@clear-code.com>2019-05-07 15:27:21 +0900
committerKouhei Sutou <kou@clear-code.com>2019-05-07 15:27:21 +0900
commitf36379af33f1312471144efe662535786fcf7edd (patch)
tree893f8cc08467bc9c82507c1d3561dc7961927cec /libsecret/Makefile.am
parentb5442654d483e959ac9ecd3a3fb9eebc8d9d8399 (diff)
downloadlibsecret-f36379af33f1312471144efe662535786fcf7edd.tar.gz
Add missing GType to flags in .gir
Here is a sample diff by this change: --- Secret-1.gir.before 2019-05-07 15:20:58.252288010 +0900 +++ Secret-1.gir.after 2019-05-07 15:26:54.314413832 +0900 @@ -1141,22 +1140,32 @@ </field> </record> <bitfield name="CollectionCreateFlags" + glib:type-name="SecretCollectionCreateFlags" + glib:get-type="secret_collection_create_flags_get_type" c:type="SecretCollectionCreateFlags"> <doc xml:space="preserve">Flags for secret_collection_create().</doc> - <member name="collection_create_none" + <member name="none" value="0" - c:identifier="SECRET_COLLECTION_CREATE_NONE"> + c:identifier="SECRET_COLLECTION_CREATE_NONE" + glib:nick="none"> <doc xml:space="preserve">no flags</doc> </member> </bitfield> Other flags such as SecretServiceFlags also have GType in .gir.
Diffstat (limited to 'libsecret/Makefile.am')
-rw-r--r--libsecret/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/libsecret/Makefile.am b/libsecret/Makefile.am
index 1d1c489..8e68d97 100644
--- a/libsecret/Makefile.am
+++ b/libsecret/Makefile.am
@@ -24,9 +24,13 @@ inc_HEADERS = \
libsecret/secret-enum-types.h \
$(NULL)
+libsecret_BUILT_ENUMS = \
+ libsecret/secret-enum-types.c libsecret/secret-enum-types.h \
+ $(NULL)
+
libsecret_BUILT = \
secret-dbus-generated.c secret-dbus-generated.h \
- libsecret/secret-enum-types.c libsecret/secret-enum-types.h \
+ $(libsecret_BUILT_ENUMS) \
$(NULL)
libsecret_PUBLIC = \
@@ -117,7 +121,7 @@ Secret_@SECRET_MAJOR@_gir_EXPORT_PACKAGES = libsecret-@SECRET_MAJOR@
Secret_@SECRET_MAJOR@_gir_INCLUDES = GObject-2.0 Gio-2.0
Secret_@SECRET_MAJOR@_gir_LIBS = libsecret-@SECRET_MAJOR@.la
Secret_@SECRET_MAJOR@_gir_CFLAGS = -I$(srcdir) -I$(builddir) -DSECRET_COMPILATION
-Secret_@SECRET_MAJOR@_gir_FILES = $(libsecret_PUBLIC)
+Secret_@SECRET_MAJOR@_gir_FILES = $(libsecret_PUBLIC) $(libsecret_BUILT_ENUMS)
Secret_@SECRET_MAJOR@_gir_SCANNERFLAGS = --c-include "libsecret/secret.h"
gir_DATA += Secret-@SECRET_MAJOR@.gir