summaryrefslogtreecommitdiff
path: root/libsecret/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-07-13 09:10:13 -0400
committerStef Walter <stefw@gnome.org>2012-07-13 15:26:28 +0200
commit6422acd085ef76d69f3182b593175d7275abd873 (patch)
tree97798d090493f28ea2ec92f7a8dceead81610f9e /libsecret/Makefile.am
parent5d725daf29b0f90654367e6b9aa2e3c6b8a44384 (diff)
downloadlibsecret-6422acd085ef76d69f3182b593175d7275abd873.tar.gz
build: Various introspection-related build fixes
Don't set PKG_CONFIG_PATH, this breaks jhbuild; instead, use --include-uninstalled to tell the scanner where to find internal libraries. Don't set _PACKAGES = gio-2.0; we already pick that up from the Gio-2.0.gir. https://bugzilla.gnome.org/show_bug.cgi?id=679852
Diffstat (limited to 'libsecret/Makefile.am')
-rw-r--r--libsecret/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/libsecret/Makefile.am b/libsecret/Makefile.am
index b52278a..1b7eb73 100644
--- a/libsecret/Makefile.am
+++ b/libsecret/Makefile.am
@@ -113,12 +113,10 @@ include $(INTROSPECTION_MAKEFILE)
INTROSPECTION_GIRS = Secret-@SECRET_MAJOR@.gir SecretUnstable-0.gir
INTROSPECTION_SCANNER_ARGS = $(INTROSPECTION_FLAGS) --warn-all --add-include-path=$(srcdir) --add-include-path=.
INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir) --includedir=.
-INTROSPECTION_SCANNER_ENV = PKG_CONFIG_PATH=$(builddir)
Secret-@SECRET_MAJOR@.gir: libsecret-@SECRET_MAJOR@.la
Secret_@SECRET_MAJOR@_gir_NAMESPACE = Secret
-Secret_@SECRET_MAJOR@_gir_PACKAGES = gobject-2.0 gio-2.0
Secret_@SECRET_MAJOR@_gir_EXPORT_PACKAGES = libsecret-@SECRET_MAJOR@
Secret_@SECRET_MAJOR@_gir_INCLUDES = GObject-2.0 Gio-2.0
Secret_@SECRET_MAJOR@_gir_LIBS = libsecret-@SECRET_MAJOR@.la
@@ -129,13 +127,12 @@ Secret_@SECRET_MAJOR@_gir_SCANNERFLAGS = --c-include "libsecret/secret.h"
SecretUnstable-0.gir: libsecret-@SECRET_MAJOR@.la libsecret-@SECRET_MAJOR@.pc
SecretUnstable_0_gir_NAMESPACE = SecretUnstable
-SecretUnstable_0_gir_PACKAGES = gobject-2.0 gio-2.0 libsecret-@SECRET_MAJOR@
SecretUnstable_0_gir_EXPORT_PACKAGES = libsecret-unstable
-SecretUnstable_0_gir_INCLUDES = GObject-2.0 Gio-2.0 Secret-@SECRET_MAJOR@
+SecretUnstable_0_gir_INCLUDES = GObject-2.0 Gio-2.0
SecretUnstable_0_gir_LIBS = libsecret-@SECRET_MAJOR@.la
SecretUnstable_0_gir_CFLAGS = -I$(top_srcdir) -I$(top_builddir) -DSECRET_COMPILATION -DSECRET_API_SUBJECT_TO_CHANGE
SecretUnstable_0_gir_FILES = $(UNSTABLE_FILES)
-SecretUnstable_0_gir_SCANNERFLAGS = --c-include "libsecret/secret.h" --identifier-prefix=Secret --symbol-prefix=secret
+SecretUnstable_0_gir_SCANNERFLAGS = --c-include "libsecret/secret.h" --identifier-prefix=Secret --symbol-prefix=secret --include-uninstalled=$(builddir)/Secret-@SECRET_MAJOR@.gir
girdir = $(datadir)/gir-1.0
gir_DATA = $(INTROSPECTION_GIRS)